XV-15 durée de nettoyage réduite

XV-15, XV-14, XV-25, Signature, Botvac, Kobold VR100, VR200 ...

Modérateurs: ycorp, chris-s, uranus-13

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Mar 11 Juin 2019 20:25

J'ai aussi ça:

WallSensorInMM=OFF: 60
BatteryVoltageInmV=14539
LeftDropInMM=OFF: 0
RightDropInMM=OFF: 0
LeftMagSensor=OFF: 32768
RightMagSensor=OFF: 32768
UIButtonInmV=3333
VacuumCurrentInmA=0
ChargeVoltInmV=23930
BatteryTemp0InC=20
BatteryTemp1InC=23
CurrentInmA=287
SideBrushCurrentInmA=0
VoltageReferenceInmV=1224
AccelXInmG=-32
AccelYInmG=4
AccelZInmG=1052
____ Buttons: ____=
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Mar 11 Juin 2019 20:30

FuelPercent=15
BatteryOverTemp=0
ChargingActive=1
ChargingEnabled=1
ConfidentOnFuel=0
OnReservedFuel=1
EmptyFuel=0
BatteryFailure=0
ExtPwrPresent=1
ThermistorPresent[0]=1
ThermistorPresent[1]=1
BattTempCAvg[0]=20
BattTempCAvg[1]=24
VBattV=14.39
VExtV=23.71
Charger_mAH=0
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Mer 12 Juin 2019 17:58

Avec les ancienne batterie certifiées Neato, même soucis... J'en ai ras le bol...
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Mer 12 Juin 2019 18:52

J'ai cherché sur le forum, sur le web.

On parle de la diode D14. Je l'ai déjà changée... La soudure serait pourrie? J'en ai d'autres, je peux essayer d'en remettre une nouvelle.
Je ne sais pas si ça vient de la base de chargement ou du robot. Y a-t-il quelqu'un pour me diagnostiquer avec les paramètres de NeatoConrol que j'ai mis plus haut

Sinon, je suis un peu au bout du bout là...

La casse n'est pas loin, ça m'emmerderait avec les 60€ de batterie que j'ai laché il y a 2 mois...
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Jean-benoit » Mer 12 Juin 2019 20:44

Bonsoir,

Il va falloir y aller par étape.
tout d'abord, il faut impérativement que les boutons du panneau de commande fonctionnent correctement. on voit ExtPwrPresent=1 ce qui doit être le push de marche ! qui reste appuyé -> vous confirmez ?
On ne voit pas de défaut de batterie leur niveau de charge est a 15%

=> Avez vous soudé correctement et dans le bon sens la diode D14

Ci joint ce que j’obtient avec Neato Control sur un robot hors de sa base de chargement.
FuelPercent=99
BatteryOverTemp=0
ChargingActive=0
ChargingEnabled=1
ConfidentOnFuel=0
OnReservedFuel=0
EmptyFuel=0
BatteryFailure=0
ExtPwrPresent=0
ThermistorPresent[0]=1
ThermistorPresent[1]=1
BattTempCAvg[0]=37
BattTempCAvg[1]=36
VBattV=16.28
VExtV=0.12
Jean-benoit
Niveau 7
Niveau 7
 
Messages: 413
Enregistré le: Mar 7 Aoû 2012 19:12

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Ven 14 Juin 2019 14:56

Nouvel élément de diagnostic c'est que après avoir acquitté l'erreur 0004 le robot se remet à charger. Et si à ce moment je débranche la station de charge et je la rebranche, il se charge sans soucis jusqu'au bout et sans me remettre l'erreur.

En charge normale sur sa base j'ai ça:

WallSensorInMM=OFF: 60
BatteryVoltageInmV=15664
LeftDropInMM=OFF: 0
RightDropInMM=OFF: 0
LeftMagSensor=OFF: 32768
RightMagSensor=OFF: 32768
UIButtonInmV=3328
VacuumCurrentInmA=0
ChargeVoltInmV=23805
BatteryTemp0InC=35
BatteryTemp1InC=34
CurrentInmA=246
SideBrushCurrentInmA=0
VoltageReferenceInmV=1224
AccelXInmG=-28
AccelYInmG=4
AccelZInmG=1060
____ Buttons: ____=
BTN_SOFT_KEY=False
BTN_SCROLL_UP=False
BTN_START=False
BTN_BACK=False
BTN_SCROLL_DOWN=False
____ Charger: ____=
FuelPercent=67
BatteryOverTemp=0
ChargingActive=1
ChargingEnabled=1
ConfidentOnFuel=0
OnReservedFuel=0
EmptyFuel=0
BatteryFailure=0
ExtPwrPresent=1
ThermistorPresent[0]=1
ThermistorPresent[1]=1
BattTempCAvg[0]=36
BattTempCAvg[1]=34
VBattV=15.55
VExtV=23.71
Charger_mAH=0

Hors de sa base j'ai ça:

WallSensorInMM=OFF: 60
BatteryVoltageInmV=15477
LeftDropInMM=OFF: 0
RightDropInMM=OFF: 0
LeftMagSensor=OFF: 32768
RightMagSensor=OFF: 32768
UIButtonInmV=3320
VacuumCurrentInmA=0
ChargeVoltInmV=210
BatteryTemp0InC=35
BatteryTemp1InC=33
CurrentInmA=246
SideBrushCurrentInmA=0
VoltageReferenceInmV=1225
AccelXInmG=-28
AccelYInmG=0
AccelZInmG=1056
____ Buttons: ____=
BTN_SOFT_KEY=False
BTN_SCROLL_UP=False
BTN_START=False
BTN_BACK=False
BTN_SCROLL_DOWN=False
____ Charger: ____=
FuelPercent=67
BatteryOverTemp=0
ChargingActive=0
ChargingEnabled=1
ConfidentOnFuel=0
OnReservedFuel=0
EmptyFuel=0
BatteryFailure=0
ExtPwrPresent=0
ThermistorPresent[0]=1
ThermistorPresent[1]=1
BattTempCAvg[0]=35
BattTempCAvg[1]=33
VBattV=15.46
VExtV=0.21
Charger_mAH=0

Merci d'avance...
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Ven 14 Juin 2019 15:00

Tu me dis: on voit ExtPwrPresent=1 ce qui doit être le push de marche ! qui reste appuyé -> vous confirmez ?

Pourtant le paramètre BTN_START=False me dit que non...

Donc pour moi le bouton "start" n'est pas enfoncé en continu.
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Ven 14 Juin 2019 16:21

Je reviens sur ce que j'ai dit au sujet de débranchement et du rebranchement de la base de chargement. Apparemment c’était 2 coups de chances puisque je l'ai refait et que ça n'a pas marché. Donc la charge complète sans erreur est aléatoire...
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Jean-benoit » Ven 14 Juin 2019 16:33

J’en conclus que le extpwrptesent est une présence tension externe
Est ce que lors du premier test le 11 juin il était sur sa base ?
Jean-benoit
Niveau 7
Niveau 7
 
Messages: 413
Enregistré le: Mar 7 Aoû 2012 19:12

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Ven 14 Juin 2019 17:42

Oui, le premier test robot sur sa base avec batterie Li-Ion Intesilo.
Les derniers paramètres postés avec les batterie d'origine.

Le fait que l'appui sur le bouton "start" ne soit pas toujours détecté comme tel dans neatoControl m'interpelle. Et ce que je ne comprends pas non plus c'est pourquoi après mes soudures de C10 et diode D14 ça a marché nickel pendant 3 semaines... Ça me rend fou. Tout ça pour économiser 300€ de rachat d'un neuf...
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Dim 16 Juin 2019 15:55

Mes paramètres en erreur et sous NeatoControl:

____ Analog: ____=
WallSensorInMM=OFF: 60
BatteryVoltageInmV=14230
LeftDropInMM=OFF: 0
RightDropInMM=OFF: 0
LeftMagSensor=OFF: 32768
RightMagSensor=OFF: 32768
UIButtonInmV=3312
VacuumCurrentInmA=0
ChargeVoltInmV=23774
BatteryTemp0InC=20
BatteryTemp1InC=24
CurrentInmA=230
SideBrushCurrentInmA=0
VoltageReferenceInmV=1224
AccelXInmG=-32
AccelYInmG=4
AccelZInmG=1052
____ Buttons: ____=
BTN_SOFT_KEY=False
BTN_SCROLL_UP=False
BTN_START=False
BTN_BACK=False
BTN_SCROLL_DOWN=False
____ Charger: ____=
FuelPercent=8
BatteryOverTemp=0
ChargingActive=0
ChargingEnabled=1
ConfidentOnFuel=0
OnReservedFuel=1
EmptyFuel=0
BatteryFailure=1
ExtPwrPresent=1
ThermistorPresent[0]=1
ThermistorPresent[1]=1
BattTempCAvg[0]=21
BattTempCAvg[1]=24
VBattV=14.23
VExtV=23.77
Charger_mAH=0

Mes paramètre erreur acquitée:

____ Analog: ____=
WallSensorInMM=OFF: 60
BatteryVoltageInmV=14190
LeftDropInMM=OFF: 0
RightDropInMM=OFF: 0
LeftMagSensor=OFF: 32768
RightMagSensor=OFF: 32768
UIButtonInmV=3306
VacuumCurrentInmA=0
ChargeVoltInmV=23829
BatteryTemp0InC=21
BatteryTemp1InC=24
CurrentInmA=227
SideBrushCurrentInmA=0
VoltageReferenceInmV=1224
AccelXInmG=-28
AccelYInmG=4
AccelZInmG=1056
____ Buttons: ____=
BTN_SOFT_KEY=False
BTN_SCROLL_UP=False
BTN_START=False
BTN_BACK=False
BTN_SCROLL_DOWN=False
____ Charger: ____=
FuelPercent=8
BatteryOverTemp=0
ChargingActive=1
ChargingEnabled=1
ConfidentOnFuel=0
OnReservedFuel=1
EmptyFuel=0
BatteryFailure=0
ExtPwrPresent=1
ThermistorPresent[0]=1
ThermistorPresent[1]=1
BattTempCAvg[0]=21
BattTempCAvg[1]=24
VBattV=14.20
VExtV=23.82
Charger_mAH=0

La dernière fois que la charge a fonctionné, j'avais VExtV=14/15. J'ai l’impression que ça foire car la base de charge me fournit une une tension très supérieur à la tension des batteries.

Du coup, comment régler le problèmes? Je n'ai jamais démonté la base de charge. Y aurait-il un composant défectueux à ce niveau?

Merci d'avance.
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Dim 16 Juin 2019 16:00

Le transformateur à l'intérieur dela base de charge me donne Output: 24V. Donc à priori rien d'anormal à ce que NeatoControl m'affiche VExtV=23.79...
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Dim 16 Juin 2019 19:00

Je viens de trouver ça sur le forum et qui ressemble beaucoup à mon soucis:

Re: Erreur 0004, le dock est-il en cause?

Messagepar kyllman » Mer 4 Avr 2018 15:20
Bonjour a tous,
Un petit message pour vous confirmer que la nouvelle carte électronique de dock a résolu le problème (https://www.ebay.fr/itm/NEW-REPAIR-KIT- ... Sw4GVYGDJI). Wall-e charge a nouveau!

Je ne me vois pas changer la carte électronique du Dock. Y a-t-il un composant en cause?
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Lun 17 Juin 2019 16:23

En charge "normale", j'ai bien 15V au Dock...

WallSensorInMM=OFF: 60
BatteryVoltageInmV=14914
LeftDropInMM=OFF: 0
RightDropInMM=OFF: 0
LeftMagSensor=OFF: 32768
RightMagSensor=OFF: 32768
UIButtonInmV=3322
VacuumCurrentInmA=0
ChargeVoltInmV=15467
BatteryTemp0InC=25
BatteryTemp1InC=27
CurrentInmA=-1835
SideBrushCurrentInmA=0
VoltageReferenceInmV=1225
AccelXInmG=-32
AccelYInmG=4
AccelZInmG=1056
____ Buttons: ____=
BTN_SOFT_KEY=False
BTN_SCROLL_UP=False
BTN_START=False
BTN_BACK=False
BTN_SCROLL_DOWN=False
____ Charger: ____=
FuelPercent=22
BatteryOverTemp=0
ChargingActive=1
ChargingEnabled=1
ConfidentOnFuel=0
OnReservedFuel=0
EmptyFuel=0
BatteryFailure=0
ExtPwrPresent=1
ThermistorPresent[0]=1
ThermistorPresent[1]=1
BattTempCAvg[0]=25
BattTempCAvg[1]=27
VBattV=14.98
VExtV=15.26

Et ça qui n'est pas à zéro...

Charger_mAH=1810
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Lun 17 Juin 2019 16:25

Une âme charitable aurait-elle une solution à mon nouveau soucis?
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Lun 17 Juin 2019 16:29

Pour tester j'ai débranché et rebranché le dock. Ça va planter je suis à nouveau à 23V et Charger_mAH=0.

J'ai l'impression qu'il ne prends la charge que quand la batterie est ultra faible voire nulle...
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Lun 17 Juin 2019 16:31

débranché rebranché à nouveau 2-3 fois et c'est reparti. J'avais batterie à 14% donc ce que j'ai dit avant sur la batterie ultra faible était une bêtise.
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

Re: XV-15 durée de nettoyage réduite

Messagepar glnc222 » Ven 21 Juin 2019 19:18

Re Wall Sensor connector JST: The Digi-Key page https://www.digikey.com/product-detail/en/ZHR-3/455-1160-ND/608602
is for the connector shell only; the specification includes "contacts not included" at the bottom of the specifications table. At the bottom of this page are links to catalog listings of the contacts (pins) sold separately. Other sellers may have the contacts packaged with the shell. There may be both male and female versions of the contacts for different uses. Consult the listings on ebay, AliExpress. Digi-Key is an industrial distributor and all shipments are from the U.S., expensive mail.
glnc222
Niveau 7
Niveau 7
 
Messages: 739
Enregistré le: Mar 2 Déc 2014 02:23

Re: XV-15 durée de nettoyage réduite

Messagepar glnc222 » Ven 21 Juin 2019 19:23

Short run times can be due to wear on the battery or defects with loss of capacity. Rapid charging and fast discharge are the symptoms of low capacity. A battery can be tested over USB by running the fan only with the Neato Control program, for a partial load around 1 amp, about 1/3 the full cleaning load. Observe how long it takes for the battery voltage to drop to around 14v from the full charge of 16v. A larger load can be applied with the battery removed from the robot using a 12v 25w auto lamp bulb, observing with a multimeter for current etc.
There have been defects in charging docks preventing full charge of the battery. The dock performance can be observed over USB with the Neato Control program to closely monitor the charging process.
Examples of charging dock repairs at http://www.robotreviews.com/chat/viewtopic.php?f=20&t=18547
glnc222
Niveau 7
Niveau 7
 
Messages: 739
Enregistré le: Mar 2 Déc 2014 02:23

Re: XV-15 durée de nettoyage réduite

Messagepar Kek-de-Mars » Sam 22 Juin 2019 05:51

Thanks. Sorry my english is not verry good. The problem of Short run times is solds by changing C10 and D14.

After 4 weeks ok, i have now a charging problem with this on NeatoControl:

VBattV=14.20
VExtV=23.82
Charger_mAH=0

Sometime but not always I resolve with disconect the dock. And I have this:

VBattV=14.98
VExtV=15.26
Charger_mAH=1810

But it is randomness... I think it is a problem with the dock but I don't find the solution. I'm looking here http://www.robotreviews.com/chat/viewto ... 20&t=18547 to try to understand.
Kek-de-Mars
Niveau 3
Niveau 3
 
Messages: 78
Enregistré le: Ven 10 Mai 2019 16:40

PrécédenteSuivante

Retourner vers Neato Robotics / Vorwerk

 


  • Articles en relation
    Réponses
    Vus
    Dernier message

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités